Formulario de contacto

Nombre

Correo electrónico *

Mensaje *

miércoles, 22 de octubre de 2014

INDICE (INDEX en inglés)

Categoría: funciones de búsqueda y referencia

Hay 2 tipos de INDICE, forma matricial y forma de referencia.

Forma matricial

Qué hace esta función?

Devuelve el valor de un elemento de una tabla o matriz seleccionado por los índices de número de fila y de columna.

Sintaxis: 

INDICE(matriz, núm_fila, [núm_columna])
  • matriz (obligatorio): es un rango de celdas o una constante de matriz.
  • núm_fila (obligatorio):  selecciona, en el rango matriz, la fila desde la cual se devolverá un valor. Si se omite núm_fila, se requiere el argumento núm_columna.
  • núm_columna (opcional): selecciona, en el rango matriz, la columna desde la cual se devolverá un valor. Si se omite núm_columna, se requiere el argumento núm_fila.

Ejemplo: 

Imagina que tenemos la siguiente tabla:
Tabla Indice
=INDICE(A1:B3,2,2) = España
=INDICE(A1:B3,1,1) = Producto

Forma de referencia

Qué hace esta función?

Devuelve el valor de un elemento de una tabla o matriz seleccionado por los índices de número de fila y de columna.

Sintaxis: 

INDICE(ref,núm_fila,[núm_columna],[núm_área])
  • ref (obligatorio): es una referencia a uno o varios rangos de celdas.
  • núm_fila (obligatorio): es el número de la fila en el argumento ref desde la que se devolverá una referencia.
  • núm_columna (opcional): es el número de la columna en el argumento ref desde la que se devolverá una referencia.
  • núm_área (opcional): selecciona un rango en el argumento ref desde el cual se devolverá la intersección de núm_fila y núm_columna. La primera área seleccionada o especificada se numera con 1, la segunda con 2 y así sucesivamente. Si se omite núm_área, INDICE usa área 1.

Ejemplo: 

Imagina que tenemos la siguiente tabla:
Tabla Indice 2
=INDICE(A1:B4,4,2) = Uruguay
=INDICE((A1:B3,A5:B7),1,2,2) = Bolivia